RequirementsDL PackageMVAPICH LibraryUserguide
MPI-Driven DL Training (TensorFlow, Pytorch, MXNet)
  1. GPU-Based Training with MVAPICH2-GDR MPI Library
  2. CPU-Based Training with MVAPICH2-X MPI Library

Horovod (see userguide)
Horovod (see userguide)


MVAPICH2-GDR
MVAPICH2-X
Userguide
MPI-Driven ML Training (MPI4cuML) mpi4cuml-0.5
MVAPICH2-GDR Userguide
Data-Parallel Training with Caffe OSU-Caffe MVAPICH2-GDR Userguide
High-Performance InfiniBand Support for TensorFlow RDMA-TensorFlow MVAPICH2-GDR Userguide

MPI4cuML 0.5


OSU-Caffe 0.9


RDMA-TensorFlow 0.9.1


MVAPICH2-GDR 2.3.7 Library

MVAPICH2-X 2.3 Library and User Guide

Combined RPM Tarballs
Stock OFED MOFED 4.X* INTEL IFS 10.10
x86_64 [GNU 4.8.5]
[GNU 4.8.5]
[GNU 4.8.5]
*Note that the MOFED 4.X RPMs were built against MOFED 4.5
  • However, these RPMs should work against the other MOFEDs with the same major MOFED version number
  • e.g MOFED 4.X RPMs should work if you have MOFED 4.0, MOFED 4.2, MOFED 4.4, or MOFED 4.5
  • Please email mvapich-help@cse.ohio-state.edu if you encounter any issues
OpenPOWER and ARM RPMs
GNU 4.9.3 GNU 4.9.3 (w/ jsrun) GNU 7.3.1 GNU 7.3.1 (w/ jsrun) GNU 8.3.1 GNU 8.3.1 (w/ jsrun) CLANG 8.0.1 CLANG 8.0.1 (w/ jsrun) XLC 16.01 XLC 16.01 (w/ jsrun)
OpenPOWER [BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
[BASIC]
[ADV.]
GNU 4.8.5 GNU 7.3.0 GNU 8.3.0 CLANG 7.0.1
AARCH64 RPMs [BASIC]
[BASIC]
[BASIC]
[ADV.]
[BASIC]
[ADV.]

User Requested RPMs


  • MOFED4.5
  • MOFED4.6
  • MOFED4.7
  • MOFED5.0
  • MOFED5.1

  • Please email us at mvapich-help@cse.ohio-state.edu if your configuration does not appear on the list or if you experience any trouble installing the library on your system.

    Please see the The HiDL Horovod Userguide for information on installing Horovod on CPU and GPU clusters.